cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Accounts Setting & My Renewals Page not loading

Hello, I was looking for information on Browser compatibility or if GD has a temporary problem loading the Accounts Settings and My Renewals Page. When I click on either of those links, all I get is the wait Icon. I am running Windows 7 with IE11, it also does not work with Chrome V68. 

7 REPLIES 7

Update on this issue, I again tried to call in to support as well chat, but after waiting 20 minutes on the support line I was disconnected. Started a chat session and nobody ever answered that one. Trying the phone again, so far 15 minutes on hold....

Having same issue with multiple browsers

Still not sure what this problem is. I got a hold of support, and they determined that since no body else has the problem on the planet, that it has to be my problem. Today However it just  started working all of a sudden on my Windows 10, and Windows 7 Boxes, but it still does not work on my main Windows 7 box. I even disabled the Eset Virus Protection, and bypassed the upstream firewall, still does not work on this computer.

 

I am having no problems with any other website portals. That is the problem with Cloud Services, once the Cloud Provider tells you its not there problem, your Screwed, where do you go next?

 

The only other thing that was really strange that I also noticed was that when I did click on Account settings, it queried a server in Canada, and an IP range that is assigned to RIPE, but does appear to terminate in San Francisco, not somewhere in Europe. Not sure why anything to do with my Account settings would be querying any server outside the US for any reason! 

I'm having the same issue with the Account Settings page. Just get a spinning wheel and nothing loads. I've tried with both Safari and Chrome for Mac. Anyone had any luck?

Hi @jeffkoke@rickbeare@tbailey

Thanks for posting in our forums. We haven't had any other reports of this. I checked with our Advanced Technical Team and there does not appear to be an issue. Is this an intermittent issue or does this occur every time you try to access the account settings and renewal page? 

KayJay - GoDaddy | Community Moderator
24/7 support available at x.co/247support

In my case my main Windows 7 box with both EI11 and Chrome never load, it is not intermittent. I have cleared Cache, Remove Eset as my virus protection, bypassed my upstream Firewall, with no luck. Today however on my Windows 10 and another Windows 7 box, started working all of sudden, after not working the last 2 days. But my main box is still not loading. 

Thanks for checking on this issue, KayJay. I've only tried this today. This is what I see when I log-in and then go to "Account Settings"

Screen Shot 2018-09-06 at 4.03.13 PM.png

This goes on forever and doesn't stop.