cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Language, Address and IP address

I speak English but live in Germany. I have a bank account that is registered to my address is Germany.

 

If I use a German IP, then your site speaks German to me, and I can't understand it. If I use a UK IP address (via VPN) then your site tries to bill me in pounds not euros and the transaction fails. Yet you know I live in Germany because I entered a German billing address.

 

Why does my IP address override my language preference and my billing address?

Why do you assume that everyone who has a German IP address understands German?

 

What am I supposed to do to resolve this?

1 ACCEPTED SOLUTION

@Gentlemantech 

 

So you could probably select United Kingdom and then change the currency. Which is located next to the country selection.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

5 REPLIES 5
Super User IV

@Gentlemantech 

 

At the bottom of the GoDaddy site there is a language setting, you should be able to change the language.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thanks, I would never have found that if you hadn't told me about it 🙂

 

But that changes the country, including the currency. Pretty much exactly the same result as if I switch my IP address to a UK one. I have a German bank account, denominated in euros not pounds. Charging me in pounds is going to fail.

 

What I need is for GoDaddy to recognise that country and language (and IP address) are different things. I need to be able to log in to de.godaddy.com, and then switch just the language to English, keeping the payment options and currency to German.

 

I see there's three listings in the country list for Switzerland, depending on language. Life would probably be easier for everyone if you could select language separately from country 😉

@Gentlemantech 

 

So you could probably select United Kingdom and then change the currency. Which is located next to the country selection.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

Hi @Gentlemantech. Thanks for your feedback. I just wanted to chime in and confirm that what @PL281 suggested is correct. If you set the region to UK, you can still choose Euros as  your currency. That would probably be the best solution for you at the moment. 

 

JesseW_0-1591642366710.png

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Thanks folks. It's not obvious, but it works 🙂