cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
Highlighted

Cannot enabled admin/root access

Hi,


I really did not know where to post, I hope I chose the right location.

As the title says I'm trying to enable admin/root access, I tried to follow this GoDaddy help page:

https://uk.godaddy.com/help/enable-adminroot-access-managed-or-fully-managed-12270

 

The problem is that I cannot see anywhere any of the controls pointed out in the article

 

  • From the My Servers control panel, click Settings.
  • Next to Admin Access, click Change.
  • Make sure Enable your admin (root and sudo) access permission is selected.

I cannot find where "My Servers" is and consequentially I cannot do all the rest.

Any video or article covering this seems to show the old user interface of Godaddy website.

 

I hope somebody can help me with this.

Thanks in advance.

 

8 REPLIES 8
Helper VI Helper VI
Helper VI

Re: Cannot enabled admin/root access

What kind of hosting do you have?
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

Re: Cannot enabled admin/root access

Hi JHasselbring,

Thanks for the quick response.

I have: Hosting - Web - Economy - Linux cPanel.

 

I hope that is what you meant to ask me.

 

Thanks again for the support.

Helper VI Helper VI
Helper VI

Re: Cannot enabled admin/root access

That explains it. You cant find your servers because you do not have any. You have a web host and as far as I know,, web host tenants do not get root access. Otherwise, giving you root access will also give you access to the other website that reside in the same server you do.
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

Re: Cannot enabled admin/root access

I see, that surely explains a lot. What I'm actually trying to do is connecting to a database remotely (using MySql workbench). When I try to connect with a user I created it says that the access was denied for the user.

 

So I read that I should grant full access to the user from phpMyAdmin by running the following statement:

grant all privileges on DATABASE_NAME.* to USERNAME@localhost identified by 'PASSWORD';

 

However, I get an error message saying that:

Access denied for user 'someWeirdUsername'@'localhost' (using password: YES)

 

Can I actually connect remotely to MySql database with my current hosting plan?

 

Thanks again for your time.

Helper VI Helper VI
Helper VI

Re: Cannot enabled admin/root access

Odd, It should've worked. This is a dumb question but, did you actually input your username and password instead of USERNAME and PASSWORD?

Also, instead of having to select the database by code, have you tried going inside the database first before running the command?

 

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com
Helper VI Helper VI
Helper VI

Re: Cannot enabled admin/root access

 GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'password' WITH GRANT OPTION;
 FLUSH PRIVILEGES;

Try this code instead

 

Replace root with your actual database user credentials.

the % will allow you to connect to your database using any password. 

 

BTW, I remember it being really hard to do this and connecting remotely was slow and sporadic.

 

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com
Helper VI Helper VI
Helper VI
Solution

Re: Cannot enabled admin/root access

Actually... go back to your cPanel and look for Remote MySQL® put % or your public IP in the box then click Add Host

 

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

Re: Cannot enabled admin/root access

Hi,

 

I just saw your answer and tried it.

Well, you officially solved my problem, it works just fine now.

 

Just for who's reading in the future what I did was going to the CPanel->Databases->RemoveMySql

Then, in the Add Access Host text box, I wrote "%" and clicked on Add Host.

 

When entering my credentials in MySql workbench it worked right away.

 

Thank you so much.