cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

ZipArchive need to be enable

Hello,

 

I have purchased a theme from themeforest and installed and I see this notice.

 

ZipArchive
 
Not installed - ZipArchive is required for importing content. Please contact your server administrator and ask them to enable it.
 
So please install this so that I can enable this.
 
thanks
2 ACCEPTED SOLUTIONS
Helper III

What kind of hosting do you have?  Do you have a shared linux host, and have access to cPanel?

 

If so, you should be able to do this yourself.  Just log in to your cPanel, and click on the icon labeled "PHP PEAR Packages" (in the Software section).  Next, in the search box (underneath the "Find a PHP Extensions and Applications Package" heading, type in "zip" and click the Go button.  On the next page, you should see a listing for Archive_Zip - simply click on the Install link on the right hand side.

View solution in original post

Hey @greg2hype. Welcome to GoDaddy Community!

 

If you have a cPanel account, I'd recommend trying to add the zip extension on the "select PHP version" page. You should be able to just put a check mark by 'zip' and then save. You may need to restart your PHP processes for the change to take effect through. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

37 REPLIES 37
Helper III

What kind of hosting do you have?  Do you have a shared linux host, and have access to cPanel?

 

If so, you should be able to do this yourself.  Just log in to your cPanel, and click on the icon labeled "PHP PEAR Packages" (in the Software section).  Next, in the search box (underneath the "Find a PHP Extensions and Applications Package" heading, type in "zip" and click the Go button.  On the next page, you should see a listing for Archive_Zip - simply click on the Install link on the right hand side.

View solution in original post

Thank you very much. Yes I have cpanel hosting.Just followed your steep and successfully installed. Thanks a lot for this help. appreciate it

I had the same issue did the same install now I get this message in Wordpress still "Important: You need to activate zip extension." also on the pear page shows "

You will need to add “/home/greg2hype/php” to the include path. You can do this by adding the following code to your script:

ini_set("include_path", '/home/greg2hype/php:' . ini_get("include_path") );"

 

not sure what else to do but it won't work still says I need to do this activate???

Hey @greg2hype. Welcome to GoDaddy Community!

 

If you have a cPanel account, I'd recommend trying to add the zip extension on the "select PHP version" page. You should be able to just put a check mark by 'zip' and then save. You may need to restart your PHP processes for the change to take effect through. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

Thank you...my theme is now working!

Hello!! I did the two steps but when I try to install the pluging with the slider shows me the same mistake again... :S

 


@JesseW wrote:

Hey @greg2hype. Welcome to GoDaddy Community!

 

If you have a cPanel account, I'd recommend trying to add the zip extension on the "select PHP version" page. You should be able to just put a check mark by 'zip' and then save. You may need to restart your PHP processes for the change to take effect through. 

 


 

Hello,

I have the same problem.

after on zip mode it is not going to save.

Thanks alot, great help.

This worked for me.

Worked for me! It was a quick fix. Also learned how to add additional extensions for php in godaddy hosting!

It would be nice if you would be more specific at what particular script/or file? you are talking about.

Followed everything on this post.  It actually says its installed, but yet still get this error on user exports. 

 

"ZipArchive class is missing on your server.
Please contact your web hosting provider and ask them to install and activate ZipArchive"

 

What the heck?

Thank you. Big help.

after installing the zip, i am getting the same issue, can you please explain the next step as i need to something in c panel or need to restart something

First I installed the zip as 

 

What to do enable the zip_open() on server shared hosting .. i have installed opencart system.. when i tried to upload.ocmod files through extension installer.. i got error as undefined function call zip_open..

Nectareon.com

I installed the ZipArchive as per jvanderb's instructions. It appears that it installed correctly on the server, but my WordPress site still does not detect the install. I went back to the PHP Pear site and now I have the following message saying:

 

You will need to add “/home/patriciahost/php” to the include path. You can do this by adding the following code to your script:

ini_set("include_path", '/home/patriciahost/php:' . ini_get("include_path") );

 

What script file am I supposed to add this to?

Great just worked for me. After installing Archive_Zip. I had it enable under "PHP Version" in Cpanel

Great just worked for me. After installing Archive_Zip.

I had it enable under "PHP Version" in Cpanel


@jvanderb wrote:

What kind of hosting do you have?  Do you have a shared linux host, and have access to cPanel?

 

If so, you should be able to do this yourself.  Just log in to your cPanel, and click on the icon labeled "PHP PEAR Packages" (in the Software section).  Next, in the search box (underneath the "Find a PHP Extensions and Applications Package" heading, type in "zip" and click the Go button.  On the next page, you should see a listing for Archive_Zip - simply click on the Install link on the right hand side.



Hi,

 

I am trying to import a slider and tried installing zip archive with the solution suggested. However, I am getting the below error:

 

Completed
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0