• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    eshrey
    New

    PHP configuration limits - .user.ini is not taking effect

    Please help.

    I have Ultimate Wordpress Hosting. I purchased a theme for my website on envato.

    But this theme requires to change PHP configuration limits on the following:

    memory_limit = 256M
    max_input_vars = 3000
    max_execution_time = 300
    post_max_size = 12M
    upload_max_filesize = 12M
    allow_url_fopen ON
    asp_tags OFF

    But connecting through SFTP I cannot change the parameters of php.ini - "permission denied".

    Adding parameters to .htaccess they do not take effect and nothing changes!!!

    <IfModule mod_php7.c>
    php_value max_input_vars 3000
    php_value memory_limit 256M
    php_value max_execution_time 300
    php_value post_max_size 12M
    php_value upload_max_filesize 12M
    php_value allow_url_fopen ON
    php_value asp_tags OFF
    </IfModule>


    I created .user.ini and entered the parameters there, but they also do not take effect and nothing changes!

    max_input_vars 3000
    memory_limit 256M
    max_execution_time 300
    post_max_size 12M
    upload_max_filesize 12M
    allow_url_fopen ON
    asp_tags OFF


    In my WordPress admin panel on GoDaddy there is no Flush Cache button (From Help: Managed WordPress> Flush Cache)

    What am I doing wrong? How should I change these settings?

    Thank you!

    3 REPLIES 3
    PL281
    Super User II

    @eshrey 

     

    Generally speaking, I don't recall if the .user.ini will work on Managed WordPress - but putting that aside for the minute, you sometimes need to "trigger" something to cause the settings to "refresh"

     

    You mentioned that there is no flush cache - can you post a screen capture of where you are NOT seeing this

     

    The only thing I'm seeing which maybe an issue with any of this is the fopen urls - I recall having a plugin that was using that and for security purposes GoDaddy has it locked down as it can be used to inject (download) files into the website without you being aware

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Thanks for your reply!

     

    Following this description (https://uk.godaddy.com/help/clear-your-cache-12444), I concluded, that I need to clear cache. Because I was making changes via SFTP (Filezilla).
    Sorry, Flush cache is in its place. But cleaning the cache did not bring the desired result ☹ Configs don't take effect even if I change .htaccess

    Ok, so what should I do about it? The theme especially does not accept the max_input_vars configuration. Now the parameter is 1000, but 3000 is needed. When installing the theme, only the basic option was offered because value of max_input_vars is such a low. Although I want a different version of the theme.

    Thank you.

    @eshrey 

     

    I've never had an issue with a theme needing specific settings like that - my recommendation would just to manually upload / extract the theme via FTP and you should be good to go

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community