Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Website in redirection loop

    Hi, in the absence of any chat support this weekend, I thought I would try the community.


    I have a managed WordPress install which we have just added the domain


    The temporary domain is


    If you load one, it redirects to the other with an error page, and vice versa.


    I've checked database, .htaccess and everything seems to be in order, yet this redirect persists.


    Anyone got any ideas?



    6 REPLIES 6
    Helper VI


    @Solitec that's odd.

    Have you checked the wp_options table? There you should make sure that siteurl and home have


    If that doesn't work, you can add them to the wp-config.php file, like this:




    Hope it helps!


    If you find my replies helpful, give me a like or kudo 🙂
    And if I solved your issue, mark it as solution 😄

    Thanks jpablo, good information!


    I checked the DB and the siteurl and home url are set correctly. 


    However, while checking the wp-config.php file, I noticed that the import script had left define('DOMAIN_CURRENT_SITE', ""); which I have now changed to
    define('DOMAIN_CURRENT_SITE', ""); 


    Another "however" (and this has been plaguing my progress) I cannot upload this, or any other executable file via FTP. It loads a 0kb file of wp-config.php and then repeatedly asks me if I want to overwrite the file, but never does. This is driving me nuts and I can't get a resolution which would allow me to fix the redirect. 


    I find the GoDaddy hosting environment to be very annoying and this is coming from someone with over 20 years experience in website creation/hosting etc.


    Any pointers on the FTP issue would be greatly appreciated.





    @Solitec that looks like you have a firewall issue which prevents you (or the software you are using) to transfer via sFTP. However, to confirm it, can you use your phone as a wifi access point in order to connect and try with that?


    Also, have you tried with a different client? My favourites are Filezilla and WinSCP.


    If everything fails, I can try upload the file for you.


    Hope it helps!

    If you find my replies helpful, give me a like or kudo 🙂
    And if I solved your issue, mark it as solution 😄

    Thanks jpablo,


    I also use Filezilla, but it's only with the GoDaddy hosting environment that I have this issue which I believe to be related to a permissions problem server-side.


    I use sFTP daily with other servers without issue.


    Thanks for your offer of help with the upload, but as this is a client account, I'll need to check with them first as I assume I'd need to give you login credentials etc?


    All the best


    @Solitec Oh, so it should be permissions problems. I offered you to upload the file because I thought it was a firewall issue and I know how frustrating it can be to not be able to upload, recently I had sftp port blocked by ISP so had to upload with phone connection.

    However, if you still want me to try, I'd need the sftp credentials.


    One last thing, another directive you can use for WP is 


    After that you should go to


    Hope it helps!

    If you find my replies helpful, give me a like or kudo 🙂
    And if I solved your issue, mark it as solution 😄

    Hey jpablo,


    Thanks for that. Your info made me check a few things. I am currently working from Greece and to check the sFTP issue, I turned ON my VPN and connected via sFTP through a UK based server. This solved the upload issue. This raises a point that are GoDaddy geo-blocking some countries?


    Second, I tried your "relocate" code and it seems to have worked! I've been developing with WordPress for many years now and I've never come across that before so thank you!


    Great help my friend! Couldn't have fixed it without you. I'll try the forum before live chat next time.