Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Cannot manage domains as a delegate

This is week 2 of this problem. I'm unable to edit any DNS entries for my delegated accounts.

No, I will not ask my clients to remove and re-add me.


I'm having this problem exactly:


Same problem on Firefox, Chrome, iOS (With a **bleep** cell connection).

It's not my PC or cell, it is absolutely GoDaddy.  Something in broken. Please fix.

Super User I
Super User I

Re: Cannot manage domains as a delegate

Hello @Taurian

So did @PL281 solution help solve your issue?

Very Respectfully,

Drew Davis
Navy Veteran and Entrepreneur | GoDaddy Pro user | "Proud to be serving others!"

*** Please note that I offer free advice on this forum. Please feel free to give me KUDOS on this topic/discussion; mark my comment as ACCEPTED SOLUTION if you believe I've helped solved your issue. Thanks! ***

Re: Cannot manage domains as a delegate

What I need is for GoDaddy to admit there is a problem and to notify us when it's finally been resolved.


It is absolutely not my role or the role of "Pro Users" to debug their system as their system is keeping me from doing my job and supporting the clients we share.

GoDaddy also needs a better way to detect this kind of problem and a better way to communicate to those who are affected. Because as of right now, the only solution is to begin the arduous process of moving dozens of domain names to a different registrar that allows me to perform my DNS modifications with ease and peace of mind while maintaining the security protocols that keep all those domains safe.

I can't believe my team and I were basically "Gaslit" by this problem. Jumping through insane hoops when in the end it was always GoDaddy and we're stuck here trying to prove it. Unintentional or not, there needs to be better process in place to deal with these kinds of problems without us having to resort to posting on this forum.

Super User III
Super User III

Re: Cannot manage domains as a delegate



I manage hundreds of domains in several accounts and I'm having no issues. What exactly is the error you're seeing?


It sounds like your issue in particular is quite frustrating but it doesn't seem to be a trend for a lot of customers. The logical path would be to find out what is different for your in comparison to everyone else. It would help to have more info.


Also, did you try the solution in this thread, as @davisdre317 mentioned? It seems to have worked for others with this issue until the bug affecting the customer's facing this issue is resolved.

I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Re: Cannot manage domains as a delegate

This is absolutely absurd. Not only is there a pinned topic about this very issue, there are other similar topics in this forum category. Yeah no, no 3rd party "super user" solutions work. Why would that even remotely be considered acceptable anyway?

Community Manager
Community Manager

Re: Cannot manage domains as a delegate

Hi @Taurian. Sorry you're having trouble with this. We've recently updated our delegate access system. Because of this, in order to regain access to the domains you managed, you will need to reach out to the account owner that gave you access and ask them to provide you with access again. If they're not sure how to do that, this post may help. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.