Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Domain suddenly not forwarding correctly on https

So, I tried to call support and apparently they can't see anything wrong but coincidentally when my domain renewed today https stopped working properly. quick rundown;

- my domain forwards to a static IP address with masking

- internal forwarding is handled by nginx reverse proxy (including redirecting all http requests to https)

- going to the domain via http displays the nginx 404 page fine still in http (this should not happen, nginx has all requests to that address redirected to https, I have no default page)

- going to the domain via https times out


- pinging the domain resolves as a GoDaddy IP rather than the forwarded IP as it did in the past

- pinging a subdomain redirecting to the same IP address resolves as the forwarded IP

- if I connect to a subdomain (forwarding to the exact same IP address) it works fine and displays the nginx 404 page

- if I use the IP address along with https it displays the nginx 404 page fine


Literally the only thing not working is accessing the page via https with the straight domain name, unfortunately I can't just "live" with this as all the nginx proxy pages are set to accept the straight domain, and the https certificate is set to the straight domain.


On a side note:

A few months ago when a GoDaddy backend update occured, also when they started using variables in the A record for forwarding, it broke my forwarding with masking, apparently they had to do something manually behind the scenes. My memory is foggy, but it was something about setting up the forwarding, quickly making another change and applying the changes before the system automatically corrected it.


Re: Domain suddenly not forwarding correctly on https

Hi @XxInvictus, thanks for posting.

If you are using domain forwarding, it would not be possible to access the domain using HTTPS. Since the forwarding of the domain is hosted and redirected through GoDaddy servers, an SSL cannot be installed on the Forwarding servers.

Pinging a Forwarded domain would never have displayed the forwarded IP address.


Based on what you described, it doesn't sound like Domain Forwarding is the best option for you. If you are forwarding to an IP address, generally you can update the DNS for the domain to resolve directly to that IP address. Perhaps this is how you had it configured in the past.


Gary - GoDaddy | Community Moderator
24/7 Support | Check System Status

Re: Domain suddenly not forwarding correctly on https


So it is not possible to use if you are forwarding with a 302?  We are adding a traffic manager to our Azure site but we can't get the DNS set on GoDaddy to allow https of the naked domain.  Only www will work.  Is this a dead end?

Re: Domain suddenly not forwarding correctly on https

Same problem. I'm finding it pretty painful that it seems impossible to make work. I'm going to be looking for alternative services this weekend.

Re: Domain suddenly not forwarding correctly on https

Did anyone get the solution?

google search result have https:// by default so those links are not working for me.

Is there any solution for it?





Community Manager
Community Manager

Re: Domain suddenly not forwarding correctly on https

Hi @jelopatel. What @GaryA mentioned above is true. Our forwarding service will not respond to HTTPS requests. HTTPS requires an SSL Certificate to be installed on the server that the domain is connected to. This isn't currently possible with our forwarding service, so HTTPS can't work. I know our product team has been looking into changing this, but I'm not sure when or if that option will become available. 


If you want your domain to respond to HTTPS requests, the best thing to do is host it on a server that will allow you to install an SSL Certificate. If that's not possible, then you may want to see if there are other providers that offer a forwarding service that would allow HTTPS requests. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.