cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Website availability issue

Hello, 

I tried many different DNS and Website availability checker for me my new website reainusa.com is working correctly with www (redirected to non-www), non-www and https and http (redirected to https) but some users and availability checker still tell me the site is not working (blank page or connection issue). I checked the DNS and made sure no host names are presented (using Cloduflare) but I can not find any issue what might be causing this (since site is working properly for me) does somebody have an idea what could be the issue? Thank you very much for your time and replies. 

1 ACCEPTED SOLUTION

@sekaba   Woo-hoo!  Glad it worked out! 😉

 

Judith
"I never lose. Either I win or I learn." ~ Me

View solution in original post

14 REPLIES 14
Super User IV

@sekaba 

 

As you are using cloudflare I don't know where you are actually hosting your domain, but it looks to be an error with your hosting provider.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Super User II

@sekaba 

 

I tried to view your site and got the error: Call to undefined function IP2Location\bcadd()

 

So in looking at your DNS, you have two A Records with two different IPs pointing to your domain.  Maybe as @PL281 noted, check with your host.  Confirm you need to have two A Records and that those two IPs are correct if you do.   😉

 

Judith
"I never lose. Either I win or I learn." ~ Me

@Muse I fixed the missing PHP module - could you kindly check if you still get the error message? (Since I don't get the message) what browser are you using if I might ask?

Thank you so much for your response

@sekaba 

 

I am still getting it - I'm on a Mac using Chrome - I'm not sure if you are using WordPress - but a quick google search suggests this maybe related to a WordPress Plugin IP 2 Location

 

Also I would double check what version of PHP you are running

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New

Thank you both for your replies, I checked and removed the wrong hostnames on godaddy (was due being moving the domain) and only have the nameservers of cloudflare for the domain. I checked and the Cloudflare DNS records are correct with two A records. I will check into the error Muse has mentioned - looks like a PHP extension is missing

Ah and I forgot to mention - I am using my own dedicated server by OVH

@Muse may you please tell me where you encountered the error? 

@sekaba 

 

As you said the 2 IPs are correct with Cloudflare. As @Muse  when you go to the site there is a big sad face with Call to undefined function IP2Location\bcadd() 

 

This says there is something with the code on your OVH server I would suggest putting up a simple HTML page to confirm the domain is pointed correctly after that you can address any PHP issues you are having on the server

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Super User III

I'll chime in that it has been working for me, checked last night and this morning.  Looks like a Joomla site, www redirects to non-www and http:// redirects to https://.

@PL281 thank you for your reply - appreciated, I will try to install the missing php extension, strange I don't get the error message but will try to fix.

Yes I checked with other Cloudflare protected sites and the two A record with different IPs seem to be correct and normal for Cloudflare (as far as I can tell)

@sekaba 

 

When I click the link in your OP that's when I see that error.  Did so just now and got the same. 😞

 

Judith
"I never lose. Either I win or I learn." ~ Me

@Muse thank you very much for testing - strange I installed the missing PHP module and don't get the error myself

@sekaba 

 

I just tried again -- and the same.  Then, cleared my cache and cookies for your site -- no change.

 

Not sure if it will matter when it comes to missing modules but do you possibly have any caching in place on your side that can be cleared?

 

Judith
"I never lose. Either I win or I learn." ~ Me

@Muse I think I was able to fix the PHP error 🙂 thank you all for your assistance

@sekaba   Woo-hoo!  Glad it worked out! 😉

 

Judith
"I never lose. Either I win or I learn." ~ Me

View solution in original post