cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Need ASP.net core 3.0 and above

Hi, I just subscribe a Window Deluxe Shared Hosting yesterday and I found that it does not support the ASP.net core 2.1 and above. Since all my projects are targeting 3.0 and in the visual studio(version 2019) even can't find asp.net core 2.0 or below(It's too old and now is 2020). May I know when is the ASP.net core 3.0 and above will be added in this platform? Or else I will ask for a refund because I can't use it at all.
Thank you.

1 ACCEPTED SOLUTION
Community Manager

Hi @hongbii. Thanks for posting. The update to 3.0 will probably happen in a future release, but I wouldn't count on that being as soon as you'd like it to be. If this is necessary for your project, you may need to find another provider or consider leasing a VPS. Refunds for hosting can be issued if the service is canceled within 48 hours for monthly purchases or 30 days for annual purchases. Please see this help article for information on requesting a refund. Refunds can not be requested here in the Community.

 

If you have difficulty getting the chat button to load, please try using a Chrome incognito browser window. Thanks!

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

3 REPLIES 3
Community Manager

Hi @hongbii. Thanks for posting. The update to 3.0 will probably happen in a future release, but I wouldn't count on that being as soon as you'd like it to be. If this is necessary for your project, you may need to find another provider or consider leasing a VPS. Refunds for hosting can be issued if the service is canceled within 48 hours for monthly purchases or 30 days for annual purchases. Please see this help article for information on requesting a refund. Refunds can not be requested here in the Community.

 

If you have difficulty getting the chat button to load, please try using a Chrome incognito browser window. Thanks!

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

Hi, is there an updated list of supported versions for windows shared hosting?

Hi there @ernestochaves , 

Here is the latest list for Windows Shared Hosting with Plesk:

 

ASP

3.0 (VBScript version 5.8)

ASP.NET (more info)

2.0 (also supports 3.0 and 3.5)
4.0 (also supports 4.5)
4.6.2

cURL

5.6.40 (PHP 5.6)
7.3.3 (PHP 7.3)

IIS

8.0/8.5 (Server 2012 vs 2012 R2)

MSSQL

mssql 2012/2014

MySQL

5.5.43

 

PHP (more info)

5.6 and 7.3

Python

2.7.15

 Perl

 5.28.0

PHPMyAdmin

4.8.4

MyLittleAdmin

3.8

IIS URL Rewrite Module

7.1.1980

Asp.net Core

2.0