cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Heartbeat Extension and Strict Transport Security

A GoDaddy security check showed problems (yellow triangle with an exclamation point inside) for both of these:

Heartbeat Extension - Enabled

Strict-Transport-Security - Disabled

However I couldn't find any reference on how to correct the problems.

Suggestions, please?

1 ACCEPTED SOLUTION

I started a chat with a GoDaddy tech for answers. She recommended I install the plugin "Really Simple SSL" - which solved the problem. Thanks for replying.

View solution in original post

5 REPLIES 5

In my case I solved it with a .htaccess file on my root folder. Add the following line to the file:

 

Header set Strict-Transport-Security "max-age=31536000" env=HTTPS

 

I hope it helps you.

I started a chat with a GoDaddy tech for answers. She recommended I install the plugin "Really Simple SSL" - which solved the problem. Thanks for replying.

View solution in original post

Thanx for posting. That Really Simple SLL plugin was all it took to enable the green lock within my browser's url bar!

THIS

This helped Strict-Transport-Security Warning for me. It did not fix Heartbeat Extension. Thanks.