cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

SSL Certificate Name Mismatch Error

Hello,

When I purchased a dedicated server here on GoDaddy, I also purchased a SSL certificate, however it's under some domain 'incapsula.com', and I don't know why. Basically the Common Name (CN) is NOT our domain and it causes error on my website since SSL certificate is issued for a different website.


Now I can't figure out how to change our Common Name, because when I try to manage our SSL there is a window which states that I need to complete validation process for my domain. And I don't know how to do that exactly. Frustrating situation to be honest. 

Can anyone help me please...
Thanks.
Dee



3 REPLIES 3
Helper V
Helper V
Solution

Re: SSL Certificate Name Mismatch Error

@daulzuma Here are some articles on verifying your domain name.

 

Verify your certificate request

Verify my certificate request (Standard Assurance) Most common

Verify domain ownership (HTML or DNS)

 

 

Here are the steps to request a cert. 

1. Request an SSL certificate

2. If the domain is not on your account you may need to Generate a CSR (certificate signing request)  

3. Verify your certificate request

 

You will only get the verification step after you requested the cert. Godaddy will never issue a cert before verification. It sound like you submitted a CSR for the wrong domain. If that's the case you will need to cancel the request and submit a new CSR with the correct domain name. 

To cancel the Request first access the SSL cert go to the Status and click on the Cancel link.

Once canceled you will need to select new certificate and follow the steps above.

 

If you have already been issues a SSL Cert you will need to follow the steps to Change your domain name (common name) for your SSL Cert.

New

Re: SSL Certificate Name Mismatch Error

My website shows a mixed content error instead of the green ssl lock. I have a WordPress blog page linked to my site.  I've installed the "Force SSL" plugin as recommended, but do I need to go through the pages and manually change all the http:// to https://? I thought that's what the plugin is supposed to do.

Also,

I added an .htaccess file to the root as suggested in the Redirect HTTP to HTTPS automatically tutorial. Still no luck. Any help would be appreciated.

Thanks,

Kyle

 

https://www.hllawgroup.com -- No green lock at all

 

https://hllawgroup.com/_wp/ -- Shows mixed content error

Re: SSL Certificate Name Mismatch Error

This is common, and almost always relatively easy to correct. 

 

In WordPress:

FIRST, go to Settings, Permalinks. Change permalinks setting to any other option and save it. Then reselect it to the permalink setting you want, and save it. This forces the site to reset links.

 

If mixed-content errors remain you will need to manually change links. Visit WhyNoPadlock.com to find specific issues.  Also, check these places:

1. Any links in page text including image links.

2. Theme's global settings, check links for logo, favicons, etc.

3. Any scripts for Google analytics, fonts, etc. must be https. You may need to access the header.php file via the Editor.

4. Check header and footer for any global links that may need to be changed in Widgets.

 

-----------------------

In HTML Websites:

Review each page and manually change all absolute links to https. (links in body copy, for images, or third party content such as google fonts, analytics, etc.)

Change canonical links on all pages to https