Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, August 4th at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 

502 Bad Gateway when uploading any image to new managed wordpress site

I am in the process of moving 5 wordpress sites from various hosting to managed hosting. They failed when I tried to run the auto export/import, so I am simply rebuilding them. I have successfully moved 3 sites already. The 4th isn't accepting images.


I have an empty new install at where I'm uploading 212 images (gifs, jpgs, png, pdfs) large and small. I can upload a few, then I get an HTTP Error in the media uploader and Bad Gateway 502 error when I return to the admin or look at the live site. After a few minutes, the Bad Gateway 502 is gone and I can again see my site, but the HTTP error recurs again with every new image I try to upload. I can't get a new image to upload successfully until some amount of time has passed, in which case I again get one more image and then the errors. I can't seem to get more than 4 images (any combination of them not always the same) before this error combo occurs.


My other sites were able to take 200-900 images through the media uploader. These images are no different in size or type.


I have tried various things: uploading one image at a time, uploading only small images or one kind, using different browsers (Chrome and Edge), using a different computer, and deleting and creating a new instance of the managed WordPress site. All still get the same combination of errors. My last resort was to SFTP them, but Wordpress won't acknowledge images inside the media admin if they don't go through the media uploader, so I'll have to code the links. I shouldn't have to do such a thing.


No plugins are on. The theme is 2016. It is absolutely pristine, so I'm at a standstill.




I'm in the same situation - HTTP error when I upload any document followed up 502 bad gateway error making the website go down for 20-30 seconds.


Very frustrating - All plugins deactivated - made no difference

Theme updated and still the issue remains. 


Happened after the latest wordpress update.