cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Elementor not working on my WordPress site--getting 500 internal server error

Good day all,

 

I have been trying to install Elementor on my WP site. It does not work, instead I get 500 internal server error. I have tried the .htaccess method, with no luck. When I switch off all the plug-ins the site works but as soon as I switch Elementor on I get the error. Please help me

1 ACCEPTED SOLUTION

Okay, so based on that fatal error, it seems that there is conflicting code in the Elementor plugin itself. 

 

First thing I would do is try to uninstall the current version and reinstall a fresh copy. This is about 50/50 on solving the issue.

 

If that does nothing, I would take the errors you're getting and contact Elementor. See if they have any possible solutions.

 

Other than that, it's using WP Premium Support, hiring a developer, or using a different site builder on that particular site. 

 

Good luck. I hope you find an answer.



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


View solution in original post

7 REPLIES 7
Super User II

Hey there @Les20,

 

If you could answer the following information, we'll be able to help you a bit better:

 

  • What is your domain name / URL?
  • Have you made any DNS changes recently? If so, how long ago did you make them?
  • What type of hosting platform are you on? (Ex. GoCentral, cPanel, Plesk, etc.)
  • What is your hosting package level? (Ex. GoCentral Personal, Deluxe cPanel, Ultimate Plesk, etc.)
  • What type of website do you have? (Ex. GoCentral, WordPress, Joomla, etc.)
  • What type of error are you experiencing?
  • Please supply any error codes you may be receiving and please be specific.
  • What steps have you taken so far to correct the issue?
  • Please provide screenshots of what you see if at all possible.


I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


Hi MrVapour,

 

Thank you for the reply,

 

What is your domain name:  nikiwear.co.za

Have you made any DNS changes recently? No

What type of hosting platform are you on? Plesk

What is your hosting package level?  Ultimate Plesk

What type of website do you have? WordPress

What type of error are you experiencing? 500 Internal Server Error

Please supply any error codes you may be receiving and please be specific:  500 Internal Server Error

What steps have you taken so far to correct the issue? toggle .htaccess and Elementor/Plug-Ins

Please provide screenshots of what you see if at all possible:

 

Regards,

Alright @Les20,

 

Could you try enabling debug for WordPress and let us know what type of error it gives then, please?

 

My guess is you will get a fatal error of some sort, but it helps to know what the content of said error is. Just enable the debugging and then refresh your site. It "should" give you something.

 

If all else fails, I'd suggest contacting the theme developer to see if they can explain the issue. If it's not a simple fix, you'll likely have to use something like WP Premium Support or hire a developer.



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


Mr Vapour,

 

Thanks, this is what i get:

 

Fatal error: Uncaught Error: Class 'Elementor\Modules\History\Module' not found in G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-content\plugins\elementor\core\modules-manager.php:51 Stack trace: #0 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-content\plugins\elementor\includes\plugin.php(525): Elementor\Core\Modules_Manager->__construct() #1 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-content\plugins\elementor\includes\plugin.php(465): Elementor\Plugin->init_components() #2 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-includes\class-wp-hook.php(286): Elementor\Plugin->init('') #3 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-includes\class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-includes\plugin.php(453): WP_Hook->do_action(Array) #5 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-settings.php(467): do_action('init') #6 G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-config.php(89): require_once('G:\\PleskVhosts\\...') #7 G:\Ple in G:\PleskVhosts\fewpageweb.co.za\nikiwear.co.za\wp-content\plugins\elementor\core\modules-manager.php on line 51

 

Regards,

Okay, so based on that fatal error, it seems that there is conflicting code in the Elementor plugin itself. 

 

First thing I would do is try to uninstall the current version and reinstall a fresh copy. This is about 50/50 on solving the issue.

 

If that does nothing, I would take the errors you're getting and contact Elementor. See if they have any possible solutions.

 

Other than that, it's using WP Premium Support, hiring a developer, or using a different site builder on that particular site. 

 

Good luck. I hope you find an answer.



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


View solution in original post

Will do.... Thank you for your time, much appreciated.

 

Best regards,

Mohambi

You're more than welcome. I wish I could have given a better answer but that's one of those errors that really needs to have someone look "under the hood" if the simple fixes don't work. 



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community