cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Issues with a theme using WooCommerce--getting 404 errors

Hi, I need somebody's real and practical help on this one. 

I've got GoDaddy's Deluxe hosting for two domains but at the moment building a website only on one www.goodgoodlife.co.uk.

Initially, it was working without any problems but since I started adding products on WooCommerce, it's absolutely terrible. 

When I upload any picture (no more than 200kb) it's frozen, says it's lost connection, goes to 404 error or internal server error, and I get emails from Jetpack that the site is down. I deleted all unnecessary pictures, plugins and themes. And kept only what I need. I'm really struggling with this as adding any product takes me forever. Can somebody please run checks on the website for me or tell me what to do? Thank you. 

2 REPLIES 2
Super User II Super User II
Super User II
Solution

Re: Issues with a theme using WooCommerce--getting 404 errors

@joannafirrisa

 

Hmmmm....  Sounds like a conflict of some sort but the fact it started after you started adding products is confusing.   

 

You stated you removed all the themes and plugins that you don't need.  That doesn't mean that what is left isn't causing a conflict of some sort.  It could be your theme is not Woo compatible. So we do have to eliminate potential conflicts first.  I have a walk-thru on my site to help you do that.

 

If you go through that process and still have issues it could be resource/memory settings.  Here's an article on Woo about that.

 

HTH! 😉

Judith
"Many of life's failures are people who did not realize how close they were to success when they gave up." ~Thomas Edison

Solution

Re: Issues with a theme using WooCommerce--getting 404 errors

@Musethank you for your advice. It looks like in my case the problem was in the theme. I changed it to one that is specifically Woo compatible and it seems to resolve the problem! Such a relief.