cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Using SMF - Need PHP 5.5 Upgrade

It only cost me $159.87 for GoDaddy to upgrade from PHP 5.3.  

Yeah, I'm a happy camper...not.  

 

11 REPLIES 11
Retired
Not applicable

Hi @Leonard2002,

 

Please explain more.............

I was told, by a source other than GoDaddy, the PHP 5.3 version is VERY outdated.  I found it odd that no one at GoDaddy ever mentioned this.  I had to find out from others!

Anyway, the outdated version caused issues with my website.  

I contacted GoDaddy and paid for the update.  I also paid for GoDaddy to do all the migration work.

My website has been down since yesterday morning.  After contacting GoDaddy today and speaking to more than one rep, I was told my website MAY be up and running TOMORROW.  

Yes, I feel very foolish that I didn't just take my business elsewhere.  

 

My website is still not up and running.  *sigh*

Retired
Not applicable

Hi @Leonard2002,

what kind of site is it and what is your domain name?

UPDATE:

 

FIVE days later, GoDaddy finally got my website back up.  Unfortunately, I have been working to correct broken items since.

What a mess!

I HIGHLY do not recommend paying them to upgrade your website for you.  

Retired
Not applicable

@Leonard2002,


@Leonard2002 wrote:

UPDATE:

 

FIVE days later, GoDaddy finally got my website back up.  Unfortunately, I have been working to correct broken items since.

What a mess!

I HIGHLY do not recommend paying them to upgrade your website for you.  

 

It sounds like the people responsible for the mess weren't godaddy!!! Your 'work' obviously helped......


 

I'm sorry you are unable to understand the chain of events.  I'll try to explain in more simple terms for you.

 

1.  I paid GoDaddy to update the PHP.

2.  I paid GoDaddy to do the migration work for me.

3.  While GoDaddy was doing the migration work, my website was offline for 5 days.

4.  After GoDaddy completed the migration work, and after my website was back online is when I worked to fix items that were still not working properly.  

 

The work that I did was AFTER the fact.  Hope the above info helps.  

 

Retired
Not applicable

Yes @Leonard2002,

its not simple terms I need, rather clear terms, but I digress. I see what you mean. It stands though to reason that a site built for one version of php may not be fully backwards compatible with all processes. 

I wish you could tell this story to all those who demand an upgrade to PHP 7 right now. Because a lot of sites won't work without some work. And to be fair it wasn't godaddy that recommended an upgrade and you were having problems before the upgrade (probably due to plugins not working and needing a newer version). You took advice from an outside source to update, godaddy just did what you requested. They upgraded the php, then migrated your data, thats all. Migrating data does not mean rewriting data, it's just moving what you have already. 

You obviously hoped that the update and migration would cure the problems you were having before the migration and upgrade. 

 

Im sorry you had extra work to do. This though can not always be in GoDaddy's control due to third party plugins etc. But I'm glad you now have it fixed. 

Take care. 

Great ASSumption, except...

 

I wanted to use a particular plug-in.  Plug-in people tell me it won't work with the outdated PHP, and that I should call GoDaddy.

I call GoDaddy and ask (notice the word "ask" - not demand) about the outdated PHP.  GoDaddy rep - "Yes, your PHP is outdated.  We can upgrade it for x amount of dollars.  In fact, we can do the migration for you, for x amount more dollars. Your website will be down for a few hours."

Me - "Great, lets do that!"

5 days later, my website is finally back up and running... for the most part.

Issues AFTER the migration, were due to not ALL files being migrated.  If I am able to do it myself, GoDaddy should have been able to do so also.

 

Retired
Not applicable

@Leonard2002,

you said, and I quote, 'I worked to fix items that were still not working properly'

not, 'I worked to install files that were not installed'.......

 

a very big difference. 

One implies that the same problems were occurring that were happening beforehand........ 😉

Your very words!! 

Have a really nice day. 👋 

Product Team

@Leonard2002

Exciting news to all GoDaddy cPanel users. Your account is now updated with the latest PHP 7.0 and 7.1! If you want to update, login to your cPanel dashboard. Then under the Software heading click “Select PHP version”. In the top left of the PHP selection page use the dropdown the PHP version you want and click set as current. You are now ready to go! But a heads-up before you update, I recommend you check you site for compatibility first. If you have any questions our customer support team is happy to help 24/7. Just call (480) 505-8877.

 - Paul Seguritan, cPanel Product Manager