This did it! Thank you so much for this! As soon as I disabled CDN it worked perfectly!